1. Benvenuti su XenForo Italia!

    Stai navigando nella nostra community come Ospite.

    Avere un account su XenForo Italia ti permetterà di creare e partecipare alle discussioni, scaricare i file di traduzione in italiano, vedere le immagini e i video a formato intero, iniziare conversazioni personali con gli altri membri del forum e di utilizzare tutte le funzioni di questo sito.

    Condividi anche tu la tua passione per XenForo!

    Registrarsi è gratis ed elimina la pubblicità

  1. najaru

    najaru Moderatore

    Una funzione chepuò interessare a molti è di aggiungere il bottone di tweet con il contatore integrato, nell'area messaggi.
    Ovviamente è possibile inserirlo ovunque, ma abbiamo deciso di inserirlo a destra in alto nel messaggio


    E' necessario aprire il template message e trovare questa parte:

    HTML:
    <div class="messageContent">
                <article><blockquote class="messageText ugc baseHtml">{xen:raw $message.messageHtml}</blockquote></article>
    
                {xen:raw $messageContentAfterTemplate}
            </div>
    
    ed incollare in seguito:
    HTML:
    <div align="right">
         <script type="text/JavaScript">
    tweetmeme_style = 'compact';
    </script>
    <script type="text/JavaScript" src="http://tweetmeme.com/i/scripts/button.JavaScript"></script>
     </div>
    




    L'effetto voluto sarà:

    retweet.jpg

    Attenzione: sembra non funzionare con il i FURL rewrite attivi. Con alcuni browser non esegue il ridirezionamento alla pagina del topic dopo aver inviato una risposta. Da verificare il perchè del problema.
     
    A giorgino piace questo elemento.
  2. Il Custode

    Il Custode Custode del Forum Membro dello Staff Licenza Verificata

    Direi che con questo codice funziona:
    HTML:
    <div class="retweet01">
          <a href="http://Twitter.com/share" class="Twitter-share-button" data-count="vertical" data-via="xFItaliait">Tweet</a><script type="text/JavaScript" src="http://platform.Twitter.com/widgets.JavaScript"></script>
    </div>
    
     
  3. Il Custode

    Il Custode Custode del Forum Membro dello Staff Licenza Verificata

    Comunque metterlo in basso è meglio, inoltre come vedi nel messaggio sopra anche il .css deve essere più raffinato per supportare quello del messaggio (ci sono errorini)
     
  4. Il Custode

    Il Custode Custode del Forum Membro dello Staff Licenza Verificata

    Levato tutto... Il pulsante funziona, ma il .css va rivisto. Occhio che manca un punto e virgola in quello che hai inserito tu :)
     
  5. najaru

    najaru Moderatore

    il punto e virgola l'ho corretto.
    altri errori non li vedo...
     
  6. Il Custode

    Il Custode Custode del Forum Membro dello Staff Licenza Verificata

    Se inserisci il pulsantone (che adesso ho eliminato) vedrai in alcuni topic con testo quotato o BB code HTML sovrapposizioni ed errori vari di allineamento
     
  7. najaru

    najaru Moderatore

    forse con un display: block; si risolve
    ora provo
     
  8. najaru

    najaru Moderatore

    vabbè....
    ho cambiato tutto il sistema, mettendolo piccolo e a capo, quindi non si sovrappone.
    Rimane comunque l'incompatibilità di questo script in questo template penso.....
     
  9. Il Custode

    Il Custode Custode del Forum Membro dello Staff Licenza Verificata

    A me funziona quello originale di Twitter
     
  10. ghiboz

    ghiboz Membro Attivo

    ma questo che c'è qui, con che codice l'avete fatto?? ho provato i 2 che avete linkato ma non funziona questo:
    [​IMG]
     
  11. ghiboz

    ghiboz Membro Attivo

  12. Claudio

    Claudio Membro Senior

  13. Il Custode

    Il Custode Custode del Forum Membro dello Staff Licenza Verificata

    Magari correggiamo il mio post ;)
     
  14. ghiboz

    ghiboz Membro Attivo

    l'unica differenza è il www.Twitter invece di Twitter, ma mi da sempre l'errore URL Required
     
  15. ghiboz

    ghiboz Membro Attivo

    risolto, il problema era che non avevo abilitato Use Full Friendly URLs.
     

Condividi questa Pagina