• Benvenuti su XenForo Italia!

    Stai navigando nella nostra community come Ospite.

    Avere un account su XenForo Italia ti permetterà di creare e partecipare alle discussioni, scaricare i file di traduzione in italiano, vedere le immagini e i video a formato intero, iniziare conversazioni personali con gli altri membri del forum e di utilizzare tutte le funzioni di questo sito.

    Condividi anche tu la tua passione per XenForo!

    Registrarsi è gratis ed elimina la pubblicità

Edo

Admin XenForo
Licenza Verificata
Punteggio reazioni
21
Punti
35
  • Autore discussione Autore discussione
  • #21
A distanza di tempo riapro questa discussione per dirvi come è andata:
L'Add-on di Andy funziona bene e obbligherebbe i nuovi iscritti a scrivere un post nella sezione Presentiamoci... ma funziona però al 90% con i nuovi che hanno scoperto che esistono i messaggi profilo e allora vanno a scrivere domande e post nei messaggi profilo "fregandosene" bellamente di presentarsi come sarebbe d'obbligo, questo porta a doverli "cazziare" uno per uno e invitarli a scrivere dove sarebbe giusto e non dove capita ... Ho anche un forum aperto in scrittura agli ospiti e vedo che i nuovi usano pure quello per scriverci un post anche se sono registrati.

Bei tempi agli albori dei News group dove ti cazziavano di brutto se solo scrivevi più di tot parole senza avvisare che il post era lungo :)

A questo punto o divento un admin che tira le orecchie di brutto a tutti coloro che non sanno dove scrivere o lascio correre. Purtroppo nell'era dei social dove anche gli analfabeti sono iscritti tenere in piedi un forum organizzato e ordinato è sempre più dura.

Scusatemi lo sfogo ma penso che sicuramente comprendiate.

Edo
 

Kintaro

Custode del Forum
Licenza Verificata
Punteggio reazioni
124
Punti
70
Basta disabilitare i messaggi profilo fino a che non hanno tot messaggi pubblici
 

Edo

Admin XenForo
Licenza Verificata
Punteggio reazioni
21
Punti
35
  • Autore discussione Autore discussione
  • #23
E' quello che pensavo pure io, ma non ho trovato il modo (o forse non ho cercato bene) per ridar loro i permessi di usare i messaggi profilo dopo un tot di messaggi postati.

Edo
 

Kintaro

Custode del Forum
Licenza Verificata
Punteggio reazioni
124
Punti
70
In pratica lo usergroup registered non deve avere i permessi di inviare messaggi profilo. Permessi che saranno attivati da una promozione che li inserira nel gruppo "Messaggi Profilo - SI".

I Dev di XenForo consiglia di avere lo usegroup registered con pochissimi permessi (quasi nulla) e poi dare permessi con usegroups appositi.

Per esempio se non ricordo male io ho "Registered" con quasi nulla e poi "Attivi" con diversi permessi base attivi.
 

Edo

Admin XenForo
Licenza Verificata
Punteggio reazioni
21
Punti
35
  • Autore discussione Autore discussione
  • #25
Grazie @Kintaro, ho capito, ma era quello che avevo provato a suo tempo, ovvero una promozione da Registered a Attivi, però avevo notato (forse ho fatto in fretta le prove) che facendo la promozione al gruppo superiore manteneva ancora i permessi del precedente gruppo. Ci riprovo sul forum di test e poi faccio sapere come va.
 

Edo

Admin XenForo
Licenza Verificata
Punteggio reazioni
21
Punti
35
  • Autore discussione Autore discussione
  • #26
Avendo già l'ambiente di test pronto ci ho provato al volo creando il gruppo Utenti attivi, creando una promozione che aggiunge gli utenti che "Non sono nel gruppo Attivi" e che hanno postato almeno 3 messaggi al gruppo Attivi e togliendo i permessi al gruppo Utenti registrati assegnandoli al nuovo gruppo Utenti attivi..
Faccio delle prove aggiungendo io a mano il gruppo ad un utente di test e il discorso fila.
Ma non fila con il cron ... che lancio ma me ne passa solo 3 ...proprio solo 3 :triste:
Ho provato a rilanciarlo più volte, ma la musica non cambia.

Provo a quel punto a fare una promozione batch filtrando i soli utenti registrati, ma anzichè trovarne più di 4.700 (utenti iscritti) me ne trova solo 720, pensando che forse lo fa a gruppi, aggiorno i primi 720 e poi riprovo ma di utenti registrati poi non me ne trova più nessuno.

Insomma lascio perdere. Penso che il mio problema risieda ancora nell'importazione fatta a suo tempo dal database di phpBB che forse ha lasciato campi sporchi nel DB ... questo lo dico perchè anche l'Add-on (vedi mess precedenti) di Andy che avevo installato ha avuto diversi problemi per aggiornare automaticamente gli utenti e alla fine solo dopo un paio di query lanciate sul DB ha sistemato le cose facendolo funzionare come doveva.

Morale della favola, terrò il tutto come sta e al massimo "cazzio" chi non si presenta dove dovrebbe.

Edo
 

Kintaro

Custode del Forum
Licenza Verificata
Punteggio reazioni
124
Punti
70
Ma non fila con il cron ... che lancio ma me ne passa solo 3 ...proprio solo 3 :triste:
Ho provato a rilanciarlo più volte, ma la musica non cambia.
ne passa solo tre perchè passa solo gli utenti che si sono collegati recentemente (non ricordo quanto tempo).
nalla sandbox prova a resettare la pwd di un utente a caso che non è stato inserito nel gruppo e riprova vedrai che passa anche lui (dopo che ti sei loggato)
 

Edo

Admin XenForo
Licenza Verificata
Punteggio reazioni
21
Punti
35
  • Autore discussione Autore discussione
  • #28
Questa non la sapevo... E penso che il tempo sia poco più di un'ora dato che i 3 passati si erano collegati poco prima...

Riprovo con calma appena ho due ore di tempo, l'ambiente di test é già attivo e poi ti faccio sapere.

Edo
 

Kintaro

Custode del Forum
Licenza Verificata
Punteggio reazioni
124
Punti
70
questo lo dico perchè anche l'Add-on (vedi mess precedenti) di Andy che avevo installato ha avuto diversi problemi per aggiornare automaticamente gli utenti e alla fine solo dopo un paio di query lanciate sul DB ha sistemato le cose facendolo funzionare come doveva.
Io continuo a ripeterlo. Andy si rifiuta di seguire gli standard e le linee guida di programmazione di XenForo. State attenti.
 

Per rispondere Entra o Registrati è Gratis…

Perchè dovresti Registrarti?

  • Partecipare e Creare Discussioni
  • Trovare Consigli e Suggerimenti
  • Condividere i tuoi Interessi
  • Informarti sulle Novità

Membri Iscritti online

Non ci sono Iscritti online al momento.

Nuove Discussioni

Ultimi Messaggi sui Profili

Bellissimo XenForo....😎
FEDERICOSCHI ha scritto sul profilo di Il Custode.
non posso scaricare la versione in italiano
Alto