• Benvenuti su XenForo Italia!

    Stai navigando nella nostra community come Ospite.

    Avere un account su XenForo Italia ti permetterà di creare e partecipare alle discussioni, scaricare i file di traduzione in italiano, vedere le immagini e i video a formato intero, iniziare conversazioni personali con gli altri membri del forum e di utilizzare tutte le funzioni di questo sito.

    Condividi anche tu la tua passione per XenForo!

    Registrarsi è gratis ed elimina la pubblicità

Klaudius

Admin XenForo
Punteggio reazioni
4
Punti
35
Come da titolo, vorrei sapere in che modo è possibile esportare uno stile.

Io nel caso specifico sono partito da uno stile, non quello di default, e poi man mano l'ho modificato fino ad arrivare a quello che volevo, in 3 fasi, poi ho creato un altro stile figlio in modo avere uno stile solo per il portale e uno solo il forum.

Il problema sorge quando devo andare a modficare qualcosa nello stile genitore, a volte capita che cambia anche il codice dell'altro...
 

Lollo

Admin XenForo
Punteggio reazioni
0
Punti
28
Stili>A fianco dello stile:"Esporta"


Inviato dal mio iPhone usando Tapatalk
 

netkingZ

Membro Senior
Licenza Verificata
Punteggio reazioni
84
Punti
55
Ciao , andrebbe visto dove hai inserito il codice di personalizzazione del Template , solitamente si inserisce tutto nel file denominato Extra.css , poi va anche detto che forse hai classi in comune fra i due template e quindi cambiando una cambi anche l'altra , andrebbe visto insomma , con le informazioni che hai dato è un po difficile capire quale sia il problema reale e come risolverlo... :)
 

Klaudius

Admin XenForo
Punteggio reazioni
4
Punti
35
  • Autore discussione Autore discussione
  • #7
Ciao , andrebbe visto dove hai inserito il codice di personalizzazione del Template , solitamente si inserisce tutto nel file denominato Extra.css , poi va anche detto che forse hai classi in comune fra i due template e quindi cambiando una cambi anche l'altra , andrebbe visto insomma , con le informazioni che hai dato è un po difficile capire quale sia il problema reale e come risolverlo... :)

sicuramente il problema dipende da quanto dici, io ho fatto tantissime modifiche al codice e non solo nel template extra.css, anche in molti altri

inzio a credere che la soluzione migliore sia partitre dal template base a fare copia-incolla delle modifiche effettuate
 

netkingZ

Membro Senior
Licenza Verificata
Punteggio reazioni
84
Punti
55
Guarda anche io in uno dei primi siti fatti con XenForo feci tante modifiche inserendo codice su codice all'interno dei vari file e non mettendo tutta la parte css nel file Extra.css , ma accortomi dell'errore mi misi di buona leva a ricercare tutti i mezzi di codice e copiarli nel file Extra.css . Ti consiglio di farlo , la dicitura corretta per richiamare l'Extra.css nei tuoi template è

<xen:require css="Extra.css" />
tieni conto anche di un altro fattore , se hai assegnato uno Stile al sito ed un altro al Forum avrai 2 file Extra.css , uno per il sito ed uno per il forum ma avendo tag uguali in comune va in confusione e sovrascrive un file sull'altro.
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
484
Punti
110
Adesso si può usare il TMS della versione 1.2.0 che aiuta parecchio a tenere tutto ordinato, anche per quanto riguarda l'EXTRA.css.
In particolare sto cercando di fare proprio un mio Add-on con tutte le modifiche di base per tutti i forum che ho. Così mi basta modificare l'Add-on per modificare tutti i forum in un colpo...
 

Per rispondere Entra o Registrati è Gratis…

Perchè dovresti Registrarti?

  • Partecipare e Creare Discussioni
  • Trovare Consigli e Suggerimenti
  • Condividere i tuoi Interessi
  • Informarti sulle Novità

Membri Iscritti online

Nuove Discussioni

Ultimi Messaggi sui Profili

Bellissimo XenForo....😎
FEDERICOSCHI ha scritto sul profilo di Il Custode.
non posso scaricare la versione in italiano
Alto