• Benvenuti su XenForo Italia!

    Stai navigando nella nostra community come Ospite.

    Avere un account su XenForo Italia ti permetterà di creare e partecipare alle discussioni, scaricare i file di traduzione in italiano, vedere le immagini e i video a formato intero, iniziare conversazioni personali con gli altri membri del forum e di utilizzare tutte le funzioni di questo sito.

    Condividi anche tu la tua passione per XenForo!

    Registrarsi è gratis ed elimina la pubblicità

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
allora io sto cercando di installare la taigachat ma non riesco a farlo allora carico la cartella upload
poi vado nel acp e carico xml ma mi dice errore non capisco il perchè :disappunto:
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
Allora quando scarichi l'Add-on trovi una cartella TaigaChat la quale contiene:
  • Add-on-TaigaChat.xml che dovrai installare dall'ACP nella sezione Add-on
  • Cartella uploadche contiene:
    • JavaScript
    • library
    • styles
  • xenPorta che non ti serve, quindi lasciala stare.
Ecco cosa devi fare:
Apri la tua applicazione FTP e collegati al server. Imposta come sovrascrivi files ma unici le cartelle (altrimenti mandi in botta il sito).
Sposta le tre cartelle JavaScript, library, styles dentro l'installazione di XenForo nella root. Puoi facilmente riconoscere la cartella giusta in quanto contiene già le cartelle JavaScript, library e styles.
Una volta che il programma FTP ha finito di copiare i files dopo carica il file .xml nell'ACP.

Schermata 01-2455954 alle 14.22.18.png
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
  1. Aggiungi il codice che richiama la chat al template forum_list sopra o sotto l'include sidebar_online_users a seconda di dove ti piace di più:
    Codice:
    <xen:include template="dark_taigachat" />
    Oppure, se desideri che la chat compaia sopra o sotto l'indice dei forum, aggiungi il codice al templtate forum_list:
    Code:
    Codice:
    <xen:include template="dark_taigachat"><xen:set var="$taigachat_alt">1</xen:set></xen:include>
    In entrambi i casi appena sopra o sotto questo codice:
    Codice:
    <xen:if is="{$renderedNodes}"><xen:include template="node_list" /></xen:if>
  2. Fatto questo configura i permessi per ogni gruppo utente.
 

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
  • Autore discussione Autore discussione
  • #7
Codice:
<xen:include template="dark_taigachat" />
devo aggiungerlo qui? sidebar_online_users ?

o nel forum_list?
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
Controlla bene di aver fatto tutto come si deve ;)
 

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
  • Autore discussione Autore discussione
  • #11
allora ho messo come mi hai detto tu le cartelle allora ho preso i file di library e gli ho messi dentro la library di XenForo e ugualmente lo fatto per la JavaScript ma la cartella taigachat che dice di non trovarla lo messa dentro essendo il nome originale in upload lo modificato in taigachat lo appena inserita ma non funziona. qual'è il problema?
 

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
  • Autore discussione Autore discussione
  • #13
??? come posso fare non riesco a risolvere :S
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
??? come posso fare non riesco a risolvere :S
Alex i passaggi sono chiari e l'Add-on funziona di certo visto il numero di utenti che lo usano... Se non ti va, vuol dire che stai sbagliando qualcosa. Fai tutto da capo accertandoti di fare tutto per bene ;)
 

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
  • Autore discussione Autore discussione
  • #15
Il custode il problema e chè se metto i file library e JavaScript dentro le cartelle gia contenenti XenForo come mi hai detto tu, se io voglio visualizzare la chat tutta intera e clicco shoutbox vicino alla scritta home - forum - shoutbox quando la clicco mi dice che non trova la cartelle taigachat, ma come mi hai detto tu io non ho fatto la cartella taigachat ma ho messo i file nelle cartelle gia esistenti di XenForo ho letto di nuovo ma non riesco a capire bene non so prova a darci un occhiata e visibile se clicchi
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
Alex quel problema dipende dal fatto che non hai messo i file giusti nelle cartelle giuste. La questione è davvero semplice.

In pratica devi aggiungere i files (ma anche le cartelle) dell'Add-on dentro le corrispondenti cartelle di XenForo.

Nel farlo, devi porre attenzione a non cancellare le cartelle di XenForo.
Il modo più semplice di farlo, come ti ho già scritto è di trascinare il contenuto della cartella upload dentro la directory di XenForo, ovvero nella root del server (se come mi sembra hai installato XenForo nel primo livello della root e non in una sottocartella come per esempio /forum/).

Ovviamente se trascini le cartelle intere e non hai impostato per bene il programma FTP succederà che upload/library sovrascriverà la cartella library di XenForo mandandoti in pappa il forum.
Quindi affinché tutto funzioni, devi semplicemente impostare il tuo programma FTP in modo che unisca le cartelle e sovrascriva i files.

Hai capito ora?
 

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
  • Autore discussione Autore discussione
  • #17
in filezilla non c'è un opzione unire caso mai prendere tutti i file di ogni cartella cioè library e JavaScript e inserirli nel library e JavaScript di XenForo ma poi esce il problema che se clicco a pieno schermo non la trova.
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
Allora apriti le strutture ad albero delle due cartelle e copiati un file alla volta controllando che corrispondano
 

Alex Nos

Membro Attivo
Punteggio reazioni
0
Punti
33
  • Autore discussione Autore discussione
  • #19
io comunque nella cartella o solo la
  • JavaScript
  • library
 

Il Custode

Custode del Forum
Membro dello Staff
Licenza Verificata
Punteggio reazioni
481
Punti
110
Esatto. Ma quelle due cartelle contengono file e forse cartelle. Controlla che la corrispondenza con quelle del server sia corretta
 

Per rispondere Entra o Registrati è Gratis…

Perchè dovresti Registrarti?

  • Partecipare e Creare Discussioni
  • Trovare Consigli e Suggerimenti
  • Condividere i tuoi Interessi
  • Informarti sulle Novità

Membri Iscritti online

Nuove Discussioni

Ultimi Messaggi sui Profili

Bellissimo XenForo....😎
FEDERICOSCHI ha scritto sul profilo di Il Custode.
non posso scaricare la versione in italiano
Alto