• Benvenuti su XenForo Italia!

    Stai navigando nella nostra community come Ospite.

    Avere un account su XenForo Italia ti permetterà di creare e partecipare alle discussioni, scaricare i file di traduzione in italiano, vedere le immagini e i video a formato intero, iniziare conversazioni personali con gli altri membri del forum e di utilizzare tutte le funzioni di questo sito.

    Condividi anche tu la tua passione per XenForo!

    Registrarsi è gratis ed elimina la pubblicità

Andrea Marucci

Admin XenForo
Punteggio reazioni
7
Punti
45
Ciao a tutti, ho provato a scrivere su XenForo.com ma per ora nessuno mi ha risposto. Ci provo anche qui per un piccolo problema estetico che mi assilla da tempo. Forse qualcuno qui dentro aveva cercato di darmi una mano tempo fa ma non ricordo bene...

Il mio forum è qui

http://forum.kog.it

e ho implementato un sistema che mi permette di avere l'header fisso e la parte inferiore scorrevole. Se provate capite cosa intendo.

il problema è che se io entro, vedo i nuovi messaggi e clicco su di un thread, lui mi porta al primo nuovo messaggio ma me lo mostra così

-1.png


invece che così come dovrebbe essere

-2.png


Non sono in grado di risolverlo da solo ma sono certo che sia solo un semplice pezzo di CSS che dovrebbe avere un valore differente invece di quello standard che, ovviamente, non tiene conto che c'è il pezzo in alto che rimane sempre fisso e visibile.

C'è qualcuno così gentile che potrebbe aiutarmi?
 

netkingZ

Admin XenForo
Licenza Verificata
Punteggio reazioni
84
Punti
55
A me al caricamento della pagina non succede quello che succede a te , mi succede solo dal momento che faccio <-- Indietro ( tornando alla pagina precedente ).
Io ho provato con Chrome.
 

netkingZ

Admin XenForo
Licenza Verificata
Punteggio reazioni
84
Punti
55
Forse una soluzione elegante potrebbe essere JQuery con questo script:

Codice:
<script>
$(document).ready(function() {
                setTimeout(function() {
                        $('HTML body').animate({
                               scrollTop: 0
                         }, 'fast');
        }, 100);
});
</script>
Cosi dovresti essere certo che non appena carica la pagina l'Header è posizionato correttamente e questo avverrebbe in nel giro di 1 sec.

Se vuoi inserire questo codice puoi inserirlo nel PAGE_CONTAINER nei template.

P.S.: Non so se vale anche se clicck su <-- Indietro , ma ti consiglio di provarlo.
 

Kintaro

Custode del Forum
Licenza Verificata
Punteggio reazioni
128
Punti
70

Andrea Marucci

Admin XenForo
Punteggio reazioni
7
Punti
45
  • Autore discussione Autore discussione
  • #5
Grazie a tutti e scusate il ritardo della mia risposta. Proverò appena possibile il suggerimento di netkingZ, non perché quello di kintaro non vada bene ma semplicemente perché non sono in grado di implementarlo, mentre l'altro sembra più alla mia portata.

Forse @netkingZ a te non funziona come dico, ma solo tramite il back, perché non sei un utente registrato. Al limite provo il tuo suggerimento e poi ti creo un accesso, se ti va, così puoi vedere in real time come funziona.

Grazie ancora...
 

netkingZ

Admin XenForo
Licenza Verificata
Punteggio reazioni
84
Punti
55
Nel file PAGE_CONTAINER appena dopo <head> inserisci:
Codice:
<script src="http://code.jquery.com/jquery-latest.min.JavaScript" type="text/JavaScript"></script>

<script>
   $(document).ready(function() {
             setTimeout(function() {
                         $('HTML body').animate({
                                         scrollTop: 0
                          }, 'fast');
             }, 100);
});
</script>
 

Andrea Marucci

Admin XenForo
Punteggio reazioni
7
Punti
45
  • Autore discussione Autore discussione
  • #8
Grazie e scusa per l'incompetenza. Ho provato ma si comporta esattamente come prima nel senso che il primo post non letto viene tagliato...
 

Andrea Marucci

Admin XenForo
Punteggio reazioni
7
Punti
45
  • Autore discussione Autore discussione
  • #10
Sicuramente. Ho fatto una prova veloce copiando e incollando e ho controllato nel codice della pagina che fosse presente il tuo codice, però non sono riuscito a vedere alcuna differenza. Riproverò quando ho un filo più di tempo e ti farò sapere...
 

Andrea Marucci

Admin XenForo
Punteggio reazioni
7
Punti
45
  • Autore discussione Autore discussione
  • #11
ho trovato su XenForo un Add-on che lo fa automaticamente così forse risolvo tutti i problemi...
 

Per rispondere Entra o Registrati è Gratis…

Perchè dovresti Registrarti?

  • Partecipare e Creare Discussioni
  • Trovare Consigli e Suggerimenti
  • Condividere i tuoi Interessi
  • Informarti sulle Novità

Membri Iscritti online

Nuove Discussioni

Alto