• Benvenuti su XenForo Italia!

    Stai navigando nella nostra community come Ospite.

    Avere un account su XenForo Italia ti permetterà di creare e partecipare alle discussioni, scaricare i file di traduzione in italiano, vedere le immagini e i video a formato intero, iniziare conversazioni personali con gli altri membri del forum e di utilizzare tutte le funzioni di questo sito.

    Condividi anche tu la tua passione per XenForo!

    Registrarsi è gratis ed elimina la pubblicità

  • per chiudere questo avviso, clicca la crocetta >>
    ATTENZIONE: Per scaricare le traduzioni, verifica la tua licenza
    Per scaricare la traduzione o per ottenere supporto devi prima verificare la validità della tua licenza XenForo. Puoi farlo a partire da questa pagina.
    Buon Download!

Lollo

Admin XenForo
Punteggio reazioni
0
Punti
28
Salve a tutti,
sulla board dove "lavoro" vi è un problema con gli avatar, precisamente nelle discussioni (solo ed esclusivamente nelle discussioni), l'avatar ha l'imbottitura solo in alto e a sinistra, mentre in basso e a destra manca. Vi lascio anche quest'immagine per capire meglio.

f86f597f9a4352b2956364f7ecea1e45.png
 

netkingZ

Admin XenForo
Licenza Verificata
Punteggio reazioni
84
Punti
55
Credo che dipenda dalle informazioni date all'avatar in riferimento alle dimensioni , forse nel crearlo hai impostato qualcosa nelle impostazioni avatar che concede "troppa libertà" .
Infatti guardando da questa pagina della tua Board : http://forum.sanfierro.org/index.php?threads/im-back.24888/

ho notato che il primo ragazzo che ha scritto ha l'avatar perfetto gli altri inceve no , hanno il problema che chiedevi te.

Quindi dai un occhiata alle impostazioni Avatar ,per prima cosa.
Credo che il problema sia proprio quello in quanto guardando anche questa discussione (http://forum.sanfierro.org/index.php?threads/ritorno-d.24786/) si nota come l'ultimo che ha scritto "Torrore" ha l'avatar perfetto mentre gli altri no , quindi le persone che hanno questo problema molto probabilmente hanno messo immagini "inopportune" dal punto di vista dimensionale , mentre "Torrore" ed altri le hanno messe con dimensioni corrette , fai un po di prove e dicci qualcosa.
 

Lollo

Admin XenForo
Punteggio reazioni
0
Punti
28
Oggi ho rivisto un po' questo problema cercando come sempre una soluzione e ho notato che andando al link dell'avatar nei topic e non solo la dimensione di quest'ultimo è di 114x114, invece di 96x96 (se non erro). Sapreste come risolvere questo problema?

Grazie in anticipo ^^
 

netkingZ

Admin XenForo
Licenza Verificata
Punteggio reazioni
84
Punti
55
Cmq io se fossi in te darei un occhiata a queste impostazioni :

Opzioni --> Generale --> Avatar
Aspetto -->Proprietà di stile -->Avatar autore discussione
Aspetto -->Proprietà di stile --> Scheda Messaggio --> Avatar

e fai delle prove inserendo questo codice :

max-height: 96px ; max-width:96px

forse risolvi il problema.
Facci sapere ... ciao
 

Lollo

Admin XenForo
Punteggio reazioni
0
Punti
28
Cmq io se fossi in te darei un occhiata a queste impostazioni :

Opzioni --> Generale --> Avatar
Aspetto -->Proprietà di stile -->Avatar autore discussione
Aspetto -->Proprietà di stile --> Scheda Messaggio --> Avatar

e fai delle prove inserendo questo codice :



forse risolvi il problema.
Facci sapere ... ciao
Non hai capito come funziona. Praticamente l'immagine dell'avatar su XenForo è un impostato come background in css nel class "avatar" e "img". Quindi le dimensioni sono quelle dell'immagine usata come background css che dovrebbero essere 96x96 ma in questo caso sono 114x114. Ho provato a risolvere con "background-size: 96px 96px" ma in questo modo si buggano gli avatar negli stati sui profili. La soluzione sarebbe quella di modificare in qualche modo la grandezza di questi avatar. Pensavo di controllare se nel file Avatar.php in XenForo/Model (se non sbaglio), ditemi voi.
 

netkingZ

Admin XenForo
Licenza Verificata
Punteggio reazioni
84
Punti
55
A parte che mi sa che quello che non ha compreso sei te , ma tolto questo particolare forse non hai compreso il funzionamento di XenForo.
XenForo è un sistema basato su MVC Freamworks e questo vuol dire che tutto il codice targarato php che vedi nella cartella Library/XenForo serve per lo scambio di dati , la ricezione di dati , l'update dei dati il delete dei dati e per altre funzioni ma nessuna di esse influenza "direttamente" la grafica.

Guarda ho provato quello che ti avevo gia spiegato e sono andato in Aspetto --> Stili --> [Nome del tuo template] --> Proprietà di stile --> Generale --> Avatar

ed ho aggiunto il codice che ti ho scritto ed ho gestito la dimensione dell'Avatar:

291fdir.jpg


Come puoi vedere mi è bastato mettere il codice che ti ho scritto il post precedente imponendo al template di mettere come minimo nel mio caso 350px sia in altezza che in larghezza e in max 400px e l'avatar si è modificato come volevo io.

Non ti resta che mettere il codice che ti ho scritto sopra nel percorso che ti ho indicato e farci sapere se ci sono altri problemi.

Ciao
 

Lollo

Admin XenForo
Punteggio reazioni
0
Punti
28
L'immagine dell'avatar è un background, quindi non varia con "max-width".
Ho risolto facendo modificare il valore di 'm' in XenForo/Model/Avatar.php portandolo da '114' a '96'. In questo modo riuploadando l'avatar il valore m di quest'ultimo sarà 96 e non 114.
 

Per rispondere Entra o Registrati è Gratis…

Perchè dovresti Registrarti?

  • Partecipare e Creare Discussioni
  • Trovare Consigli e Suggerimenti
  • Condividere i tuoi Interessi
  • Informarti sulle Novità

Membri Iscritti online

Ultimi Messaggi sui Profili

Cerco al traduzione per XenForo 2 (poiattaforma che sto usando per il forumlibri).
Bellissimo XenForo....😎

Discussioni Simili

Alto